Заголовок



//Создать соответствие и заполнить элементы соответствия

СоответствиеНаименований = Новый Соответствие();
СоответствиеНаименований["ИНН"] = "Соответствие_для_ИНН";
СоответствиеНаименований["НомерСчёта"] = "Соответствие_для_НомерСчёта";

 

//Получить значения соответствия

Сообщить(СоответствиеНаименований["ИНН"]);

Сообщить(СоответствиеНаименований["НомерСчёта"]);




//"ТаблПолеМод" - табличное поле на модально открытой форме
//"ТаблПолеВлад" - табличное поле на форме-владельце

Для Каждого Стр Из ЭтаФорма.ТаблПолеМод Цикл
        НовСтр = ВладелецФормы.ТаблПолеВлад.Добавить();
        НовСтр.Поле1 = Стр.Поле1;
        НовСтр.Поле2 = Стр.Поле2;
КонецЦикла;



//В данном примере число в ячейке будет заключено в скобки
Процедура ТабличноеПолеПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
      Если 1 = 1 Тогда
            ОформлениеСтроки.Ячейки.Сумма.ЦветТекста = WebЦвета.Серый;
            ОформлениеСтроки.Ячейки.Сумма.Текст = "(" + СокрЛП(ДанныеСтроки.Сумма) + ")";
      КонецЕсли;
КонецПроцедуры



//Это уберет элемент отбора из списка отборов
ЭлементыФормы.ТаблПоле.НастройкаОтбораСтрок.РеквТабЧасти1.Доступность = Ложь;


//Установить значение отбора в табличном поле. Включить отбор по полю
ЭлементыФормы.ТаблПоле.ОтборСтрок.РеквТабЧасти1.Значение = Справочники.СтатьиОтделов.Статья1;
ЭлементыФормы.ТаблПоле.ОтборСтрок.РеквТабЧасти1.Использование = Истина;
//Или так
ЭлементыФормы.ТаблПоле.ОтборСтрок.РеквТабЧасти1.Установить

          (Справочники.СтатьиОтделов.Статья1, Истина);


//Если у отбора на табличном поле установлено значение, это запретит его менять
ЭлементыФормы.ТаблПоле.НастройкаОтбораСтрок.РеквТабЧасти1.Доступность = Ложь;



//"Элемент" у "ВыбратьИзСписка" - элемент, где появится выпадающий список выбора
СписокВыбора = Новый СписокЗначений;
СписокВыбора.Добавить(Справочники.СценарииПланирования.Сценарий1);
СписокВыбора.Добавить(Справочники.СценарииПланирования.Сценарий2);
ВыбрЭлемент = ВыбратьИзСписка(СписокВыбора, Элемент);
Отбор.Сценарий.Установить(ВыбрЭлемент.Значение);



Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
        Если ЭтотОбъект.ПометкаУдаления <> Ссылка.ПометкаУдаления Тогда
                Сообщить(
"Вы не можете помечать на удаление");
                Отказ = Истина;
        КонецЕсли;
КонецПроцедуры
назад 1 2 3 4 5 6 7 8 9 10 ... 14далее