Заголовок



//ТабДок - табличный документ
//После вывода очередной области в табличный документ "ЭлементыФормы.ТабДок.
//ВысотаТаблицы" покажет номер текущей (последней) строки табличного документа
ЭлементыФормы.ТабДок.Область(ВерхняяСтрока,ПерваяКолонка,ЭлементыФормы.
                     ТабДок.ВысотаТаблицы,ПоследняяКолонка).Объединить();



http://1cexpo.ru/obuchenie-1s-predpriyatie/23-prakticheskoe-ispolzovanie-zaprosov-v-1s-8/44-tabliczy-registrov.html
http://www.ops.org.ua/P9/Zaprosy.php


 

 

//Виртуальная таблица "Остатки"
ВЫБРАТЬ * ИЗ РегистрНакопления.Товары.Остатки(&ДатНач, &ДатКон, Номенклатура = &Номенклатура И Организация = &Организация) КАК Остатки

 

 

 

//Виртуальная таблица "Обороты"
//Периодичность:
Период (не разворачивать), Регистратор, День, Неделя, Декада, Месяц, Квартал, Полугодие, Год
ВЫБРАТЬ * ИЗ РегистрНакопления.Товары.Обороты(&ДатНач, &ДатКон, Периодичность, Номенклатура = &Номенклатура И Организация = &Организация) КАК Обороты

 

 

//Виртуальная таблица "Остатки и обороты"
//Периодичность: Период (не разворачивать), Регистратор, День, Неделя, Декада, Месяц, Квартал, Полугодие, Год
 //МетодДополнения: Движения или ДвиженияИГраницыПериода (умолч.)
ВЫБРАТЬ * ИЗ РегистрНакопления.Товары.ОстаткиИОбороты(&ДатНач, &ДатКон, Периодичность, МетодДополнения, Номенклатура = &Номенклатура И Организация = &Организация) КАК ТоварыОстаткиИОбороты




//ТаблицаДанных - название табличной части
//ПриНачалеРедактирования - предопределенная процедура табличной части
//"КакойТоРеквизит" - реквизит табличной части, которому присваивается "КакоеТоЗначение"
//при добавлении новой строки или при копировании
Процедура ТаблицаДанныхПриНачалеРедактирования(Элемент, НоваяСтрока, Копирование)
     Если НоваяСтрока Или Копирование Тогда
          Элемент.ТекущиеДанные.КакойТоРеквизит = КакоеТоЗначение;
     КонецЕсли;
КонецПроцедуры;



//"ВыбКонтрагента" - переменная с типом "Справочник.Контрагенты"
//Все проводки принадлежат объекту "Операция"

Опер = СоздатьОбъект("Операция");
    
//Фильтр по контрагенту
Если ПустоеЗначение(ВыбКонтрагента) = 0 Тогда
        Опер.ИспользоватьСубконто(ВидыСубконто.Контрагенты, ВыбКонтрагента);
КонецЕсли;
    
//Перебор, обход проводок
Опер.ВыбратьОперацииСПроводками(НачДата, КонДата, СчетПоКоду("КакойТоСчет"),,1,);
Пока Опер.ПолучитьПроводку() = 1 Цикл
        Сообщить("----------------");
        //Значение реквизита "Контрагент" документа из Субконто2
        Сообщить(Опер.Дебет.Субконто(2).Контрагент);
        //Значение реквизита "НомерДок" документа из Субконто2
        Сообщить(Опер.Дебет.Субконто(2).НомерДок);
        //Номер документа, который сформировал проводку
        Сообщить(Опер.ТекущийДокумент().ПолучитьАтрибут("НомерДок"));
        //Документ, который сформировал проводку
        Сообщить(Опер.ТекущийДокумент());
         //Номер проводки
         Сообщить(Опер.НомерПроводки());
        //Сумма проводки
        Сообщить(Опер.Сумма);
КонецЦикла;



//Реквизит1, Реквизит2, Реквизит3 - реквизиты документа
//В Реквизит3 (с типом "Справочник.Контрагенты")
//помещается значение из "Справочник.Контрагенты"

НовыйДок = СоздатьОбъект("Документ.Платежка");
НовыйДок.Новый();
        
НовыйДок.Реквизит1 = "ЗначениеРеквизита1";
НовыйДок.Реквизит2 = "ЗначениеРеквизита2";
        
СпрКонтрагенты = СоздатьОбъект("Справочник.Контрагенты");
СпрКонтрагенты.НайтиПоРеквизиту("РеквизитГдеИскать", "ТоЧтоШщется", 1);
Если СпрКонтрагенты.Выбран() > 0 Тогда
       НовыйДок.Реквизит3 = СпрКонтрагенты.ТекущийЭлемент();
Иначе
       Сообщить("В СпрКонтрагенты ничего не найдено");
КонецЕсли;
        
НовыйДок.Записать();
НовыйДок.Провести();



//Создать таблицу значений

ТабЗначений = СоздатьОбъект("ТаблицаЗначений");
ТабЗначений.НоваяКолонка("Кол1", "Число", 10, 2);
ТабЗначений.НоваяКолонка("Кол2", "Дата");
ТабЗначений.НоваяКолонка("Кол3", "Строка", 30);

 

//Добавить запись в таблицу значений

ТабЗначений.НоваяСтрока();
ТабЗначений.Кол1 = 50;
ТабЗначений.Кол2 = ПеремДата;
ТабЗначений.Кол3 = "Строка";

 

//Поиск значения "ТоЧтоИщется" в колонке "Кол2"

Если ТабЗначений.НайтиЗначение("ТоЧтоИщется",,"Кол2") = 0 Тогда
        Сообщить("Не найдено");
Иначе
        Сообщить("Найдено");
КонецЕсли;


назад 1 2 3 4 5 6 7 8 9 10 ... 14далее