Заголовок



//"Состав" - имя табличной части
//"ДатаНаЭтикетку" - значение, которое необходимо найти
//"НазваниеРеквизита" - по какому реквизиту искать
//"Номенклатура" - реквизит, которые необходимо изменить

ВыбраннаяМашина = Справочники.Параметры.НайтиПоНаименованию(Машина.Наименование).ПолучитьОбъект();
ВыбраннаяМашина.Состав.Найти("Дата", "НазваниеРеквизита").Номенклатура = НовоеЗначение;
ВыбраннаяМашина.Записать();



//Создание структуры
Новый Структура("Счет, Организация", ЗначениеСчет, ЗначениеОрганизация);


//Создание структуры
Стр = Новый Структура;
Стр.Вставить("Ключ1", 1);
Стр.Вставить("Ключ2", 2);
Стр.Вставить("Ключ3", 3);


//Перебор элементов структуры
Для Каждого ЭлементСтруктуры Из Стр Цикл
    Сообщить(ЭлементСтруктуры.Ключ + " = " + Строка(ЭлементСтруктуры.Значение));
КонецЦикла;



//Длина строки
СтрДлина("Строчка")


//Заменить символы в строке
ПолучившаясяСтрока = СтрЗаменить("ИсходнаяСтрока", "ЧтоМеняем", "НаЧтоМеняем")


//Подстрока
Сред(Строка, НачНомер, ЧислоСимволов)



//Проверить существование файла. Файл существует
ИмяФайла = "С:\test.txt";
ФайлИмпорта = Новый Файл(ИмяФайла);
Если ФайлИмпорта.Существует() Тогда
    Сообщить("Файл cуществует");
КонецЕсли;


//Скопировать файл
КопироватьФайл("ПутьОткуда", "ПутьКуда");


//Стереть файлы
УдалитьФайлы(ИмяФайла);



ЭтаФорма.Панель.ЦветФона = WEBЦвета.ЛососьСветлый;



//1
Файл = Новый ЗаписьТекста("C:\test.txt", КодировкаТекста.ANSI, Символы.ПС);
Файл.ЗаписатьСтроку("Строка2");
Файл.Записать("Строка3");
Файл.Закрыть();


//2
Текст = Новый ТекстовыйДокумент;
Текст.Прочитать("catalog.txt", КодировкаТекста.ANSI);
Текст.ЗаменитьСтроку(52, "Установка оборудования " + Стоимость);
Текст.ВставитьСтроку(53, "Замена оборудования... ");
Текст.УдалитьСтроку(10);
Текст.ДобавитьСтроку("Конец файла");
Для н = 1 По Текст.КоличествоСтрок() Цикл
    стр = Текст.ПолучитьСтроку(н);
    Сообщить(стр);
КонецЦикла;
Текст.Записать("catalog2.txt",КодировкаТекста.ANSI);
Текст.ТолькоПросмотр = Истина;
Текст.Показать();
назад 1 ... 4 5 6 7 8 9 10 11 12 ... 14далее