Заголовок



Функция ПолучитьСтрокуИзДаты(ДатаВх)
         День = ДатаЧисло(ДатаВх);
         ДеньСтр = ?(День < 10, "0"+Строка(День), Строка(День));
         Месяц = ДатаМесяц(ДатаВх);
         МесяцСтр = ?(Месяц < 10, "0"+Строка(Месяц), Строка(Месяц));
         Год = ДатаГод(ДатаВх);
         Рез = ДеньСтр+"/"+МесяцСтр+"/"+Строка(Год);
         Возврат Рез;
КонецФункции  

 

DateB = ПолучитьСтрокуИзДаты(НачДата);
DateE = ПолучитьСтрокуИзДаты(КонДата);
    
strDateB = "CONVERT(DateTime,'"+DateB+"',104)";
strDateE = "CONVERT(DateTime,'"+DateE+"',104)";

 

strQuery = "SELECT *    
|        FROM table
|        WHERE DocDate between " + strDateB + " and " + strDateE + "
|";




Server = "ServerName";    //Имя сервера
DataBase = "DBName";      //Имя базы данных
Login = "sa";                      //Логин
Password = "secretpsw";   //Пароль
    
Connection = CreateObject("ADODB.Connection");
ConnectionString = "driver={SQL Server};"+"server="+СокрЛП(Server)+";"+"uid="+СокрЛП
              (Login)+"; "+"pwd="+СокрЛП(Password)+";"+"Database="+СокрЛП(Database);
Connection.ConnectionTimeOut = 600;
Connection.CommandTimeout = 300;
    
Connection.Open(ConnectionString);

Payments = CreateObject("ADODB.RecordSet");
Payments.ActiveConnection = Connection;
    
strQuery = "
          |    SELECT Field1, Field2
          |    FROM Payments    
          |";
    
Payments.Open(strQuery);

While Payments.EOF = 0 Do
          Сообщить(Payments.Fields("Field1").Value);
          Сообщить(Payments.Fields("Field2").Value);
          Payments.MoveNext();
EndDo;
    
Payments.Close();
ПустоеЗначение(Payments);
Connection.Close();
ПустоеЗначение(Connection);



СпрФирмы = СоздатьОбъект("Справочник.Фирмы");    
СпрФирмы.НайтиПоНаименованию("ООО Ромашка", 0);
ВыбФирмы = СпрФирмы.ТекущийЭлемент();



В свойствах флажков должна вызываться процедура  ПереклФлаги(Контекст)

Процедура ПереклФлаги(ГрКонт)
       Флаг1 = 0;
       Флаг2 = 0;
       Флаг3 = 0;
    
       Если ГрКонт.Форма.АктивныйЭлемент() = "Флаг1" Тогда Флаг1 = 1; КонецЕсли;
       Если ГрКонт.Форма.АктивныйЭлемент() = "Флаг2" Тогда Флаг2 = 1; КонецЕсли;
       Если ГрКонт.Форма.АктивныйЭлемент() = "Флаг3" Тогда Флаг3 = 1; КонецЕсли;
КонецПроцедуры



//Подключиться к Excel
Попытка
    Эксель = Новый COMОбъект("Excel.Application");
Исключение
    Сообщить(ОписаниеОшибки() + "Exсel не загрузился почему-то");
    Возврат;
КонецПопытки;

//Открыть файл
Книга = Эксель.WorkBooks.Open("ПолныйПутьКФайлуXLS");

//Выбрать лист. Можно по имени или по порядковому номеру
Лист = Книга.WorkSheets("Данные");
        
//Получить значение ячейки с координатами А,1 (колонку можно указывать как буквой, так и порядковым номером)
НомерСтроки = 1;
НомерКолонки = 1;
Сообщить(Лист.Cells(НомерСтроки, НомерКолонки).Value);
        
//Получить количество строк и колонок
КолСтрок = Эксель.Cells.CurrentRegion.Rows.Count;
КолКолонок = Эксель.Cells.CurrentRegion.Columns.Count;
Сообщить("Строк - " + КолСтрок + "; Колонок - " + КолКолонок);
        
//Обязательно закрытьсоединение, иначе процесс Excel остается в памяти
Эксель.Quit();
Теги: , Excel, Эксель



//Период - период в периодическом регистре сведений
//"СчетДт, СчетКт, Организация" - измерения регистра, по которым будет производиться отбор
//СчетДт, СчетКт, Организация - значения измерений регистра, по которым будет производиться отбор. Важен порядок следования


Отбор = Новый Структура("СчетДт, СчетКт, Организация", СчетДт, СчетКт, Организация);
ТабЗначений = РегистрыСведений.Проводки.СрезПоследних(Период, Отбор);
назад 1 2 3 4 5 6 7 8 9 10 ... 14далее