Заголовок



//"EAN-8" – значение
//"код EAN-8" – отображение в списке

ЭлементыФормы.ПолеВвода2.СписокВыбора.Добавить("EAN-8", "код EAN-8");
ЭлементыФормы.ПолеВвода2.СписокВыбора.Добавить("EAN-13", "код EAN-13");
ЭлементыФормы.ПолеВвода2.СписокВыбора.Добавить("EAN-128", "код EAN-128");



//Создать dbf-файл, добавить поле, добавить запись
DbfФайл1 = Новый XBase;
DbfФайл1.Поля.Добавить("Name", "S", 100);
    
DbfФайл1.Кодировка = КодировкаXBase.ANSI;
DbfФайл1.СоздатьФайл(Константы.ПутьКБазеДанных.Получить() + "Обработки\machine.dbf");
    
Сотрудники = Справочники.Сотрудники.Выбрать();
Пока Сотрудники.Следующий() Цикл
    DbfФайл1.Добавить();
    DbfФайл1.Name = Сотрудники.Наименование;
    DbfФайл1.Записать();
КонецЦикла;
DbfФайл1.ЗакрытьФайл();


//Чтение dbf-файла, обход, перебор
DbfФайл2 = Новый XBase;
DbfФайл2.ОткрытьФайл(Константы.ПутьКБазеДанных.Получить() + "Обработки\machine.dbf", , Истина);
DbfФайл2.Первая();
Пока НЕ DbfФайл2.ВКонце() Цикл
    Сообщить(DbfФайл2.Name);
    DbfФайл2.Следующая();
КонецЦикла;
DbfФайл2.ЗакрытьФайл();


//Изменение записей, Поиск записей в dbf-файле (прямой перебор)
DbfФайл3.Первая();
Пока НЕ СокрЛП(DbfФайл3.mashina) = "Жигуль" Цикл //Нужная запись становится текущей
    DbfФайл3.Следующая();
КонецЦикла;
DbfФайл3.УстановитьЗначениеПоля("max_skorost", 80);
DbfФайл3.УстановитьЗначениеПоля("kol_koles", 4);
DbfФайл3.Записать();
DbfФайл3.ЗакрытьФайл();



//ВидПродукции, ПериодС, ПериодПо, Номенклатура, НачОст, Приход, Расход, КонОст - параметры областей макета
//Результат - результат запроса

Макет = ПолучитьМакет("МакетОтчета");
    
ОбластьШапка = Макет.ПолучитьОбласть("Шапка");
ОбластьШапка.Параметры.ВидПродукции = ВидПродукции;
ОбластьШапка.Параметры.ПериодС = Формат(ПериодС, "ДФ = dd.MM.yy");
ОбластьШапка.Параметры.ПериодПо = Формат(ПериодПо, "ДФ = dd.MM.yy");
ТабДок.Вывести(ОбластьШапка);
    
ОбластьЗаголовок = Макет.ПолучитьОбласть("ЗаголовокТаблицы");
ОбластьЗаголовок.Параметры.ПериодС = Формат(ПериодС, "ДФ = dd.MM.yy");
ОбластьЗаголовок.Параметры.ПериодПо = Формат(ПериодПо, "ДФ = dd.MM.yy");
ТабДок.Вывести(ОбластьЗаголовок);
    
//Секция "Итог"
Выборка1 = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам, );
Пока Выборка1.Следующий() Цикл
    //Секция "Данные"
    Выборка2 = Выборка1.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам, );
    Пока Выборка2.Следующий() Цикл
        //Вывод секции "Данные"
        ОбластьДанные = Макет.ПолучитьОбласть("Данные");
        ОбластьДанные.Параметры.Номенклатура = Выборка2.Номенклатура;
        ОбластьДанные.Параметры.НачОст = Выборка2.НачОст;
        ОбластьДанные.Параметры.Приход = Выборка2.Приход;
        ОбластьДанные.Параметры.Расход = Выборка2.Расход;
        ОбластьДанные.Параметры.КонОст = Выборка2.КонОст;
        ТабДок.Вывести(ОбластьДанные);
    КонецЦикла;
    //Вывод секции "Итог"
    ОбластьИтог = Макет.ПолучитьОбласть("Итог");
    ОбластьИтог.Параметры.НачОст = Выборка1.НачОст;
    ОбластьИтог.Параметры.Приход = Выборка1.Приход;
    ОбластьИтог.Параметры.Расход = Выборка1.Расход;
    ОбластьИтог.Параметры.КонОст = Выборка1.КонОст;
            
    ТабДок.Вывести(ОбластьИтог);
КонецЦикла;



Процедура КнопкаВыполнитьНажатие(Кнопка)
    V8 = Новый COMОбъект("V8.Application");
    Попытка
        Открытие = V8.Connect("File=""" + КаталогБазы + """;Usr=""" + Пользователь + """;");
    Исключение
        Предупреждение("База данных не открыта");
        Возврат;
    КонецПопытки;

    Документ = V8.Документы.РасходнаяНакладная.СоздатьДокумент();
    ФормаДокумента = Документ.ПолучитьФорму();
    ФормаДокумента.ОткрытьМодально();
КонецПроцедуры






?(Условие, ЕслиУсловиеВыполняется, ЕслиУсловиеНеВыполняется)



//"РежимДиалогаВопрос.ДаНет" – Какие кнопки будут видны
//0 - таймаут
//"КодВозвратаДиалога.Нет" – Активная кнопка
//"Вопрос" - Заголовок
//" = КодВозвратаДиалога.Нет" - ответ на вопрос

 

Если Вопрос("Закрыть форму ?", РежимДиалогаВопрос.ДаНет, 0, КодВозвратаДиалога.Нет, "Вопрос") = КодВозвратаДиалога.Нет Тогда ...

назад 1 ... 5 6 7 8 9 10 11 12 13 14далее