Заголовок



//ТЗ - таблица значений, которая помещается в менеджер временных таблиц с имененм "ВТ_ТЗ".
//Она будет использована в подзапросе

МенеджерВТ = Новый МенеджерВременныхТаблиц;
Запрос = Новый Запрос();
Запрос.МенеджерВременныхТаблиц = МенеджерВТ;
Запрос.Текст
= "
        |Выбрать
        |    *
        |Поместить
        |    ВТ_ТЗ
        |Из
        |    &ТЗ Как ТЗ
        |";
Запрос.УстановитьПараметр("ТЗ", ТЗ);
Запрос.Выполнить();
        
Запрос.Текст
= "
        |Выбрать
        |    *
        |Из
        |    Документ.ОтгрузкаПокупателю.Товары
        |Где
        |    Ссылка В (Выбрать ДокОтгрузка Из ВТ_ТЗ)
        |";    
    
ТзДокументы = Запрос.Выполнить().Выгрузить();
МенеджерВТ.Закрыть();



ТЗ = Новый ТаблицаЗначений;
ТЗ.Колонки.Добавить("Поле1");
ТЗ.ЗаполнитьЗначения(0, "Поле1");
ТЗ.Колонки.Добавить("Поле2");
ТЗ.ЗаполнитьЗначения(8, "Поле2");



Если НЕ ПостроительОтчета.Результат.Пустой() Тогда
        Выборка = ПостроительОтчета.Результат.Выбрать();
        Пока Выборка.Следующий() Цикл
                ТабличноеПоле.ДобавитьСтроку();
                нСтрока = ТабличноеПоле.ТекущаяСтрока;
                ЗаполнитьЗначенияСвойств(нСтрока, Выборка);
        КонецЦикла;
КонецЕсли;



//Форму списка можно передать в процедуру или функцию
//"ДокументСписок" - форма списка, она может быть отфильтрована

Построитель = Новый ПостроительОтчета;
Построитель.ИсточникДанных = Новый ОписаниеИсточникаДанных(ДокументСписок);
Выборка = Построитель.Результат.Выбрать();
Пока Выборка.Следующий() Цикл
    Сообщить(Выборка.Ссылка);
КонецЦикла;



//Создать дерево значений
Дерево = Новый ДеревоЗначений();
Дерево.Колонки.Добавить("Поле1");
Дерево.Колонки.Добавить("Поле2");

        
//Создать элемент (узел) верхнего уровня
НовСтрДерева = Дерево.Строки.Добавить();
НовСтрДерева.Поле1 = Значение1;
НовСтрДерева.Поле2 = Значение2;

            
//Создать подчиненный элемент (узел) к строке "НовСтрДерева"
НовПодчСтрДерева = НовСтрДерева.Строки.Добавить();
НовПодчСтрДерева.Поле1 = Значение1;
НовПодчСтрДерева.Поле2 = Значение2;



//Создать колонку с типом "Документ"
ТЗ = Новый ТаблицаЗначений();
МассивТипов = Новый Массив;
МассивТипов.Добавить(Тип("ДокументСсылка.ОтгрузкаПокупателю"));
ДопустимыеТипы = Новый ОписаниеТипов(МассивТипов);
ТЗ.Колонки.Добавить("КолонкаДок", ДопустимыеТипы);


//Создать колонку с типом "Строка"
КС = Новый КвалификаторыСтроки(1000);
МассивС = Новый Массив;
МассивС.Добавить(Тип("Строка"));
ОписаниеТиповСтр = Новый ОписаниеТипов(МассивС, ,КС ,);
ТЗ.Колонки.Добавить("КолонкаСтрока", ОписаниеТиповСтр);


//Создать колонку с типом "Число"
КЧ = Новый КвалификаторыЧисла(12,2);
МассивЧ = Новый Массив;
МассивЧ.Добавить(Тип("Число"));
ОписаниеТиповЧ = Новый ОписаниеТипов(МассивЧ, , ,КЧ);
ТЗ.Колонки.Добавить("КолонкаСтрока", ОписаниеТиповЧ);
назад 1 2 3 4 5 6 7 8 9 10 ... 14далее