Заголовок



//В данном примере число в ячейке будет заключено в скобки
Процедура ТабличноеПолеПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
      Если 1 = 1 Тогда
            ОформлениеСтроки.Ячейки.Сумма.ЦветТекста = WebЦвета.Серый;
            ОформлениеСтроки.Ячейки.Сумма.Текст = "(" + СокрЛП(ДанныеСтроки.Сумма) + ")";
      КонецЕсли;
КонецПроцедуры



//Оформление полей (колонок) табличного поля
//"ТабПоле" - имя табличного поля
//"ШрифтШапки" - объект класса "Шрифт"
ФормаВыбора.ЭлементыФормы.ТабПоле.Колонки["НазваниеКолонки"].ТекстШапки = "Шапка";
ФормаВыбора.ЭлементыФормы.ТабПоле.Колонки["НазваниеКолонки"].ГоризонтальноеПоложениеВШапке = ГоризонтальноеПоложение.Центр;
ШрифтШапки = Новый Шрифт("Comic Sans MS", 12, Ложь);
ФормаВыбора.ЭлементыФормы.ТабПоле.Колонки["НазваниеКолонки"].ШрифтШапки = ШрифтШапки;
ФормаВыбора.ЭлементыФормы.ТабПоле.Колонки["НазваниеКолонки"].Ширина = 8;
ФормаВыбора.ЭлементыФормы.ТабПоле.Колонки["НазваниеКолонки"].ЦветФонаПоля = WEBЦвета.БледноБирюзовый;



//Оформление строк табличного поля
Процедура  ПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
    //Рассчитать содержимое ячейки строки табличного поля
    ДанныеСтроки["Колонка1"] = ДанныеСтроки["Колонка2"] - ДанныеСтроки["Колонка3"];

    //Цвет ячейки строки табличного поля
    ОформлениеСтроки.Ячейки.Колонка1.ЦветФона = WEBЦвета.Золотой;
КонецПроцедуры