Заголовок



Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Nls\CodePage]
"1250"="c_1251.nls"
"1251"="c_1251.nls"
"1252"="c_1251.nls"



//Поле формы списка не связано с каким-либо измерением, ресурсом или реквизитом регистра
Процедура РегистрСведенийСписокПриВыводеСтроки(Элемент,ОформлениеСтроки,ДанныеСтроки)
    ОформлениеСтроки.Ячейки["Организация"].УстановитьТекст
    (ДанныеСтроки.КакойТоРеквизитРегистра.КакойТоРеквизитРеквизитаРегистра.Наименование);
КонецПроцедуры;



Процедура ПоказатьСтруктуру(Структ) Экспорт
    ТабДок = Новый ТабличныйДокумент;
    ОбластьЗаголвка = ТабДок.ПолучитьОбласть(1, , 1, );
    ДетальнаяСтрока = ТабДок.ПолучитьОбласть(1, , 1, );
    КоличествоКолонок = 2;
                
    Область = ОбластьЗаголвка.Область(1, 1);
    Область.Текст = "Ключ";
    Область.ЦветФона = WEBЦвета.Желтый;
        
    Область = ОбластьЗаголвка.Область(1, 2);
    Область.Текст = "Значение";
    Область.ЦветФона = WEBЦвета.Желтый;
        
    ТабДок.Вывести(ОбластьЗаголвка);
        
    Для Каждого СтрокаСтруктуры Из Структ Цикл
        Область = ДетальнаяСтрока.Область(1, 1);
        Область.Текст = Строка(СтрокаСтруктуры.Ключ);
                        
        Область = ДетальнаяСтрока.Область(1, 2);
        Область.Текст = Строка(СтрокаСтруктуры.Значение);
                
        ТабДок.Вывести(ДетальнаяСтрока);
    КонецЦикла;
                
    ТабДок.Показать();
КонецПроцедуры



Процедура ПоказатьТаблицуЗначений(ТабЗначений, ФайлКудаСохранять = Неопределено, Показать = Истина) Экспорт
    ТабДок = Новый ТабличныйДокумент;
    ОбластьЗаголвка = ТабДок.ПолучитьОбласть(1, , 1, );
    ДетальнаяСтрока = ТабДок.ПолучитьОбласть(1, , 1, );
    КоличествоКолонок = ТабЗначений.Колонки.Количество();
        
    Для КолонкаТЗ = 0 По КоличествоКолонок - 1 Цикл
        Область = ОбластьЗаголвка.Область(1, КолонкаТЗ + 1);
        Область.Текст = ТабЗначений.Колонки[КолонкаТЗ].Имя;
        Область.ЦветФона = WEBЦвета.Желтый;
    КонецЦикла;
    ТабДок.Вывести(ОбластьЗаголвка);
        
    Для Каждого СтрокаТЗ Из ТабЗначений Цикл
        Для ТекущееПоле = 0 По КоличествоКолонок - 1 Цикл
            Область = ДетальнаяСтрока.Область(1, ТекущееПоле + 1);
            Область.Текст = СтрокаТЗ[ТекущееПоле];
        КонецЦикла;
        ТабДок.Вывести(ДетальнаяСтрока);
    КонецЦикла;
        
    Если Показать Тогда
        ТабДок.Показать();
    КонецЕсли;
        
    Если Не ФайлКудаСохранять = Неопределено Тогда
        Попытка
            ТабДок.Записать(ФайлКудаСохранять, ТипФайлаТабличногоДокумента.XLS);
        Исключение
        КонецПопытки;
    КонецЕсли;
КонецПроцедуры



Если РеквизитДата = Дата("00010101000000") Тогда
    Сообщить("РеквизитДата = Неопределено");
КонецЕсли;



Попытка
    Справочники["ВидСправочника"].ВыбратьИерархически();
    Сообщить("Справочник иерархический");
Исключение
    Сообщить("Справочник  не иерархический");
КонецПопытки;
назад 1 2 3 4 5 6 7 8 9 10 ... 14далее