Заголовок



//Расшифровка на табличный документ (обработка Выбора на Поле Табличного Документа)
Процедура ТабДокВыбор(Элемент, ВыбраннаяСтрока, Колонка, СтандартнаяОбработка)
    ФормаДок = Документы[ВыбраннаяСтрока["Док"].Имя].ПолучитьФормуНовогоДокумента();
    ФормаДок.Открыть();
    СтандартнаяОбработка = Ложь;
КонецПроцедуры


//Расшифровка на справочник (обработка Выбора на Поле Табличного Документа)
Если Колонка.Имя = "Номенклатура" Тогда
    ЭлементСпр = Справочники.Номенклатура.НайтиПоНаименованию(ВыбраннаяСтрока[Колонка.Имя]);
    ЭлементСпр.ПолучитьФорму().Открыть();
    СтандартнаяОбработка = Ложь;
КонецЕсли;


//Расшифровка на Табличное поле (обработка Выбора на Поле Табличного Документа)
//"Документ" - имя колонки в табличном поле. В ней находится ссылка (результат запроса) на документ

Процедура ТабПолеДокиВыбор(Элемент, ВыбраннаяСтрока, Колонка, СтандартнаяОбработка)
        Форма = ВыбраннаяСтрока["Документ"].Ссылка.ПолучитьОбъект().ПолучитьФорму("ФормаДокумента");
        Форма.Открыть();
        СтандартнаяОбработка = Ложь;
КонецПроцедуры



//1
Для Каждого Док Из Метаданные.Документы Цикл
    ДокСсылка = Документы[Док.Имя].ПустаяСсылка();
    Для Рекв = 0 По ДокСсылка.Метаданные().Реквизиты.Количество() - 1 Цикл
        Сообщить(Док.Имя + "|" + Док.Синоним + "|" + ДокСсылка.Метаданные().Реквизиты[Рекв].Имя + "|" + ДокСсылка.Метаданные().Реквизиты[Рекв].Тип);
    КонецЦикла;
КонецЦикла;
//2
Если Объект.Метаданные.Реквизиты.Найти("ИмяРеквизита") = Неопределено Тогда
    Сообщить("Нет такого реквизита");
КонецЕсли;



//Поиск файлов в директории по шаблону наименования
//Разархивировать

ЗипФайлыОбмена = НайтиФайлы("C:/Директория1", "Message_*.zip");
Для Каждого ЗипФайлОбмена Из ЗипФайлыОбмена Цикл
    ИзвлечьИзЗип = Новый ЧтениеZIPФайла(ЗипФайлОбмена.ПолноеИмя);
    ИзвлечьИзЗип.ИзвлечьВсе(ДиректорияОбмена);
    ИзвлечьИзЗип.Закрыть();
КонецЦикла;

//Архивирование файлов
ЗипАрхив = Новый ЗаписьZipФайла(ИмяФайлаАрхива, , , МетодСжатияZIP.Сжатие, УровеньСжатияZIP.Оптимальный, );
ЗипАрхив.Добавить("C:/Директория1/Файл.txt");
ЗипАрхив.Записать();



СписокРегистров = Новый СписокЗначений;
СписокРегистров.Добавить("Регистр1");
СписокРегистров.Добавить("Регистр2");
СписокРегистров.Добавить("Регистр3");
    
//Открыть окно выбора из списка значений
ВыбранныйРегистр = СписокРегистров.ВыбратьЭлемент();
        
Если ВыбранныйРегистр.Значение = "Регистр2" Тогда
    Сообщить("Выбрано значение Регистр2");
КонецЕсли;



//"ТабЧастьПараметрыМашин" - имя табличной части
Для Каждого СтрокаТабЧасти Из ЭтотОбъект.ТабЧастьПараметрыМашин Цикл
    Сообщить(СтрокаТабЧасти.Машина);
    Сообщить(СтрокаТабЧасти.Продукция);
КонецЦикла;



Макет = ВнешниеОбработки.Создать("С:\1\Обработка1.epf").ПолучитьМакет("МакетОбработки1");
назад 1 ... 5 6 7 8 9 10 11 12 13 ... 14далее