Заголовок



//Создать таблицу значений

ТабЗначений = СоздатьОбъект("ТаблицаЗначений");
ТабЗначений.НоваяКолонка("Кол1", "Число", 10, 2);
ТабЗначений.НоваяКолонка("Кол2", "Дата");
ТабЗначений.НоваяКолонка("Кол3", "Строка", 30);

 

//Добавить запись в таблицу значений

ТабЗначений.НоваяСтрока();
ТабЗначений.Кол1 = 50;
ТабЗначений.Кол2 = ПеремДата;
ТабЗначений.Кол3 = "Строка";

 

//Поиск значения "ТоЧтоИщется" в колонке "Кол2"

Если ТабЗначений.НайтиЗначение("ТоЧтоИщется",,"Кол2") = 0 Тогда
        Сообщить("Не найдено");
Иначе
        Сообщить("Найдено");
КонецЕсли;





Процедура ПоказатьТаблицуЗначений(ТабЗначений, ФайлКудаСохранять = Неопределено, Показать = Истина) Экспорт
    ТабДок = Новый ТабличныйДокумент;
    ОбластьЗаголвка = ТабДок.ПолучитьОбласть(1, , 1, );
    ДетальнаяСтрока = ТабДок.ПолучитьОбласть(1, , 1, );
    КоличествоКолонок = ТабЗначений.Колонки.Количество();
        
    Для КолонкаТЗ = 0 По КоличествоКолонок - 1 Цикл
        Область = ОбластьЗаголвка.Область(1, КолонкаТЗ + 1);
        Область.Текст = ТабЗначений.Колонки[КолонкаТЗ].Имя;
        Область.ЦветФона = WEBЦвета.Желтый;
    КонецЦикла;
    ТабДок.Вывести(ОбластьЗаголвка);
        
    Для Каждого СтрокаТЗ Из ТабЗначений Цикл
        Для ТекущееПоле = 0 По КоличествоКолонок - 1 Цикл
            Область = ДетальнаяСтрока.Область(1, ТекущееПоле + 1);
            Область.Текст = СтрокаТЗ[ТекущееПоле];
        КонецЦикла;
        ТабДок.Вывести(ДетальнаяСтрока);
    КонецЦикла;
        
    Если Показать Тогда
        ТабДок.Показать();
    КонецЕсли;
        
    Если Не ФайлКудаСохранять = Неопределено Тогда
        Попытка
            ТабДок.Записать(ФайлКудаСохранять, ТипФайлаТабличногоДокумента.XLS);
        Исключение
        КонецПопытки;
    КонецЕсли;
КонецПроцедуры



Тз = Новый ТаблицаЗначений;
Тз.Колонки.Добавить("Юзер");
СтрокаТз = Тз.Добавить();
СтрокаТз.Юзер = "Юзер1";
СтрокаТз = Тз.Добавить();
СтрокаТз.Юзер = "Юзер2";

Переменная = ТЗ[0].Юзер;



//ТабПолеВыбора - табличное поле
//ТЗ - таблица значений (источник данных для табличного поля)
//"КолонкаТаблицыЗначений" - колонка таблицы значений, по которой производится поиск значения "ИскомоеЗначение"
//"ИскомоеЗначение" - значение, которое необходимо найти в колонке "КолонкаТаблицыЗначений" в таблице значений

ФормаВыбора.ЭлементыФормы.ТабПолеВыбора.Значение = ТЗ;
ФормаВыбора.ЭлементыФормы.ТабПолеВыбора.СоздатьКолонки();
ФормаВыбора.ЭлементыФормы.ТабПолеВыбора.ТекущаяСтрока = Тз.Найти("ИскомоеЗначение", "КолонкаТаблицыЗначений");
ФормаВыбора.ОткрытьМодально();



//ТабПолеВыбора - наименование табличного поля
//Результат = Запрос.Выполнить()
//Тз = Запрос.Выполнить().Выгрузить();

ФормаВыбора = ЭтотОбъект.ПолучитьФорму("ФормаВыбора");
ФормаВыбора.ЭлементыФормы.ТабПолеВыбора.Значение = Запрос.Выполнить().Выгрузить();
//ФормаВыбора.ЭлементыФормы.ТабПолеВыбора.Значение = Результат.Выгрузить();
//ФормаВыбора.ЭлементыФормы.ТабПолеВыбора.Значение = Тз;
ФормаВыбора.ЭлементыФормы.ТабПолеВыбора.СоздатьКолонки();
ФормаВыбора.ВладелецФормы = ЭтаФорма;
ФормаВыбора.ОткрытьМодально();