Заголовок



СпрФирмы = СоздатьОбъект("Справочник.Фирмы");    
СпрФирмы.НайтиПоНаименованию("ООО Ромашка", 0);
ВыбФирмы = СпрФирмы.ТекущийЭлемент();



Все скачиваемые с этого сайта файлы являются архивами. Так как многие системные администраторы имеют пагубную привычку запрещать загружать из интернета архивы - расширение всех файлов заканичивается цифрой "1". После загрузки файла ее необходимо удалить.


Для сохранения файла воспользуйтесь пунктом "Сохранить объект как ..." из меню правой кнопки мыши.

 

 

Справочник по реестру Win XP    скачать

 

Справочник по реесту Win 7   скачать

 

 

Сайт автора  user.alexanderklimov.ru




//Расшифровка на табличный документ (обработка Выбора на Поле Табличного Документа)
Процедура ТабДокВыбор(Элемент, ВыбраннаяСтрока, Колонка, СтандартнаяОбработка)
    ФормаДок = Документы[ВыбраннаяСтрока["Док"].Имя].ПолучитьФормуНовогоДокумента();
    ФормаДок.Открыть();
    СтандартнаяОбработка = Ложь;
КонецПроцедуры


//Расшифровка на справочник (обработка Выбора на Поле Табличного Документа)
Если Колонка.Имя = "Номенклатура" Тогда
    ЭлементСпр = Справочники.Номенклатура.НайтиПоНаименованию(ВыбраннаяСтрока[Колонка.Имя]);
    ЭлементСпр.ПолучитьФорму().Открыть();
    СтандартнаяОбработка = Ложь;
КонецЕсли;


//Расшифровка на Табличное поле (обработка Выбора на Поле Табличного Документа)
//"Документ" - имя колонки в табличном поле. В ней находится ссылка (результат запроса) на документ

Процедура ТабПолеДокиВыбор(Элемент, ВыбраннаяСтрока, Колонка, СтандартнаяОбработка)
        Форма = ВыбраннаяСтрока["Документ"].Ссылка.ПолучитьОбъект().ПолучитьФорму("ФормаДокумента");
        Форма.Открыть();
        СтандартнаяОбработка = Ложь;
КонецПроцедуры



//ЭлСправочника – элемент справочника
//Параметры – имя табличной части справочника
//"Параметр" – поле, в котором производится поиск
//"Фото" – значение, которое необходимо найти в поле "Параметр"
//.ЗначениеПР – поле, из которого необходимо взять результат поиска


ЭлСправочника.Параметры.Найти("Фото", "Параметр").ЗначениеПР



//"Пользователи1С", "Принтеры" - имена справочников
//В справочнике "Пользователи1С" есть поле "Принтер" с типом "Принтеры". Оно будет заполняться с помощью формы выбора
//"ИмяПользователя()" - возвращает имя текущего пользователя
СпрПользователи = Справочники.Пользователи1С;
Пользователь = СпрПользователи.НайтиПоНаименованию(ИмяПользователя());
ФормаПринтера = Справочники.Принтеры.ПолучитьФормуВыбора();


//Создание нового элемента справочника
//Установить значение поля (реквизита) справочника с помощью формы выбора другого справочника
Если Пользователь = СпрПользователи.ПустаяСсылка() Тогда
    НовыйЮзер = СпрПользователи.СоздатьЭлемент();
    НовыйЮзер.Наименование = ИмяПользователя();
    НовыйЮзер.Принтер = ФормаПринтера.ОткрытьМодально();
    НовыйЮзер.Записать();
КонецЕсли;
    
    
//Изменение записи (элемента) справочника
//Выборка элементов справочник с помощью структуры
//Обход выборки элементов справочника
Пользователь = СпрПользователи.НайтиПоНаименованию(ИмяПользователя());
ОтборПользователь = Новый Структура("Наименование");
ОтборПользователь.Наименование = ИмяПользователя();
ВыборкаПользователь = СпрПользователи.Выбрать(,,ОтборПользователь,);
Пока ВыборкаПользователь.Следующий() Цикл
    ОбъектПользователь = ВыборкаПользователь.ПолучитьОбъект();
    ОбъектПользователь.Принтер = ФормаПринтера.ОткрытьМодально();
    Если Не ОбъектПользователь.Принтер = Справочники.Принтеры.ПустаяСсылка() Тогда
        ОбъектПользователь.Записать();
    КонецЕсли;
КонецЦикла;