Заголовок
1С, Dbf–файл, Запись, Чтение, Изменение записей, Добавление полей, Поиск записей, Перебор, Цикл, Получить значение константы, УстановитьЗначениеПоля, Кодировка
//Создать dbf-файл, добавить поле, добавить запись
DbfФайл1 = Новый XBase;
DbfФайл1.Поля.Добавить("Name", "S", 100);
    
DbfФайл1.Кодировка = КодировкаXBase.ANSI;
DbfФайл1.СоздатьФайл(Константы.ПутьКБазеДанных.Получить() + "Обработки\machine.dbf");
    
Сотрудники = Справочники.Сотрудники.Выбрать();
Пока Сотрудники.Следующий() Цикл
    DbfФайл1.Добавить();
    DbfФайл1.Name = Сотрудники.Наименование;
    DbfФайл1.Записать();
КонецЦикла;
DbfФайл1.ЗакрытьФайл();


//Чтение dbf-файла, обход, перебор
DbfФайл2 = Новый XBase;
DbfФайл2.ОткрытьФайл(Константы.ПутьКБазеДанных.Получить() + "Обработки\machine.dbf", , Истина);
DbfФайл2.Первая();
Пока НЕ DbfФайл2.ВКонце() Цикл
    Сообщить(DbfФайл2.Name);
    DbfФайл2.Следующая();
КонецЦикла;
DbfФайл2.ЗакрытьФайл();


//Изменение записей, Поиск записей в dbf-файле (прямой перебор)
DbfФайл3.Первая();
Пока НЕ СокрЛП(DbfФайл3.mashina) = "Жигуль" Цикл //Нужная запись становится текущей
    DbfФайл3.Следующая();
КонецЦикла;
DbfФайл3.УстановитьЗначениеПоля("max_skorost", 80);
DbfФайл3.УстановитьЗначениеПоля("kol_koles", 4);
DbfФайл3.Записать();
DbfФайл3.ЗакрытьФайл();