Заголовок
1С, справочник, создать элемент справочника, изменить элемент справочника, найти элемент справочника, ИмяПользователя, НайтиПоНаименованию, СоздатьЭлемент, Структура
//"Пользователи1С", "Принтеры" - имена справочников
//В справочнике "Пользователи1С" есть поле "Принтер" с типом "Принтеры". Оно будет заполняться с помощью формы выбора
//"ИмяПользователя()" - возвращает имя текущего пользователя
СпрПользователи = Справочники.Пользователи1С;
Пользователь = СпрПользователи.НайтиПоНаименованию(ИмяПользователя());
ФормаПринтера = Справочники.Принтеры.ПолучитьФормуВыбора();


//Создание нового элемента справочника
//Установить значение поля (реквизита) справочника с помощью формы выбора другого справочника
Если Пользователь = СпрПользователи.ПустаяСсылка() Тогда
    НовыйЮзер = СпрПользователи.СоздатьЭлемент();
    НовыйЮзер.Наименование = ИмяПользователя();
    НовыйЮзер.Принтер = ФормаПринтера.ОткрытьМодально();
    НовыйЮзер.Записать();
КонецЕсли;
    
    
//Изменение записи (элемента) справочника
//Выборка элементов справочник с помощью структуры
//Обход выборки элементов справочника
Пользователь = СпрПользователи.НайтиПоНаименованию(ИмяПользователя());
ОтборПользователь = Новый Структура("Наименование");
ОтборПользователь.Наименование = ИмяПользователя();
ВыборкаПользователь = СпрПользователи.Выбрать(,,ОтборПользователь,);
Пока ВыборкаПользователь.Следующий() Цикл
    ОбъектПользователь = ВыборкаПользователь.ПолучитьОбъект();
    ОбъектПользователь.Принтер = ФормаПринтера.ОткрытьМодально();
    Если Не ОбъектПользователь.Принтер = Справочники.Принтеры.ПустаяСсылка() Тогда
        ОбъектПользователь.Записать();
    КонецЕсли;
КонецЦикла;