Заголовок
1С, Форма с паролем, ОткрытьМодально, Пароль, Ввод пароля
//Эта процедура для основной формы. На этой форме происходит вызов формы ввода пароля
Процедура ДействияФормыкнРедактироватьТабЧасть(Кнопка)
    Если ЭтотОбъект.ПолучитьФорму("ФормаПароль").ОткрытьМодально(20) = "КакойТоПароль" Тогда

        //Действие, если пароль правильный
    Иначе
        //Действие, если пароль НЕ правильный
    КонецЕсли;
КонецПроцедуры


//Эта процедура для формы ввода пароля. На этой форме находится только один элемент - ПолеВводаПароль
Процедура ПолеВводаПарольПриИзменении(Элемент)
    ЭтаФорма.Закрыть(ЭтаФорма.ЭлементыФормы.ПолеВводаПароль.Значение);
КонецПроцедуры