Заголовок
1С, внешняя компонента AddHook.dll, перехват событий клавиатуры, события клавиатуры
//Компонента AddHook.dll служит для перехвата событий клавиатуры.
//Подключение внешней компоненты AddHook.dll должно находиться в процедуре "ПриНачалеРаботыСистемы" или "ПриОткрытии".
//Переменную "GlobalReg" нужно объявить в глобальном модуле (Перем GlobalReg Экспорт;).
Процедура ПриНачалеРаботыСистемы()
    ЗагрузитьВнешнююКомпоненту("AddHook.dll");
    GlobalReg = Новый("AddIn.AddHookExtension");
    GlobalReg.HookEnabled = 1;    // Включаем Hook
КонецПроцедуры


//В процедуре "ПередЗавершениемРаботыСистемы" необходимо отключить внешнюю компоненту AddHook.dll
Процедура ПередЗавершениемРаботыСистемы(Отказ)
    GlobalReg.HookEnabled = 0;
    GlobalReg = 0;
КонецПроцедуры


//Обработка событий клавиатуры должна находиться в процедуре "ВнешнееСобытие(Источник, Событие, Данные)"
Процедура ВнешнееСобытие(Источник, Событие, Данные)
    Если Данные = "00038" Тогда
        Сообщить("Нажата кнопка Стрелка вверх");
    КонецЕсли;
КонецПроцедуры

 


Скачать внешнюю компоненту AddHook.dll